• 文章
  • 在线工具

CentOS8安装Docker报错package docker-ce-3:19.03.8-3.el7.x86_64 requires containerd.io >= 1.2.2-3

安装Docker报错 推荐 热门
42 140829

1、问题描述:

     CentOS8安装Docker报错package docker-ce-3:19.03.8-3.el7.x86_64 requires containerd.io >= 1.2.2-3

2、错误展示:

[root@iZbp1d8bd3d50zlx7kccj2Z /]# yum -y install docker-ce
Last metadata expiration check: 0:09:43 ago on Sun 22 Nov 2020 01:55:52 PM CST.
Error: 
 Problem: package docker-ce-3:19.03.13-3.el7.x86_64 requires containerd.io >= 1.2.2-3, but none of the providers can be installed
  - cannot install the best candidate for the job
  - package containerd.io-1.2.10-3.2.el7.x86_64 is filtered out by modular filtering
  - package containerd.io-1.2.13-3.1.el7.x86_64 is filtered out by modular filtering
  - package containerd.io-1.2.13-3.2.el7.x86_64 is filtered out by modular filtering
  - package containerd.io-1.2.2-3.3.el7.x86_64 is filtered out by modular filtering
  - package containerd.io-1.2.2-3.el7.x86_64 is filtered out by modular filtering
  - package containerd.io-1.2.4-3.1.el7.x86_64 is filtered out by modular filtering
  - package containerd.io-1.2.5-3.1.el7.x86_64 is filtered out by modular filtering
  - package containerd.io-1.2.6-3.3.el7.x86_64 is filtered out by modular filtering
  - package containerd.io-1.3.7-3.1.el7.x86_64 is filtered out by modular filtering
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

3、解决问题:

     由于centos8默认使用podman代替docker,所以需要安装一下containerd.io。

     安装前请先执行下面一句

 yum install https://download.docker.com/linux/fedora/30/x86_64/stable/Packages/containerd.io-1.2.6-3.3.fc30.x86_64.rpm

接着继续安装。



评论
或者使用社交账号快捷登录